Jump to content
  • 0

CORS Problem


bitmonky
 Share

Question

Hi All, I am Testing with the Free Version (Not Enterprise)

https://antsrv.bitmonky.com:5443/WebRTCApp/pcIndex.html?dur=2&name=s17621-2200-1&wzID=xdxeFeJLTOUIRQBZ

Trying to get it to signal my main applicaton on another server using nodesJS  installed on the same  server as  the antmedia server but on port :13380

Have Tried these configs in my /usr/local/antmedia/webapps/WebRTCApp/WEB-INF/web.xml

Unfortunately none of this seems to have any effect on the server.

        <filter>
                <filter-name>CorsFilter</filter-name>
                <filter-class>io.antmedia.filter.CorsHeaderFilter</filter-class>
               <init-param>
                    <param-name>cors.allowed.origins</param-name>
                    <param-value>https://bitmonky.com:13380</param-value>
                </init-param>
                <init-param>
                        <param-name>cors.allowed.methods</param-name>
                        <param-value>GET,POST,HEAD,OPTIONS,PUT,DELETE</param-value>
                </init-param>
                <init-param>
                  <param-name>cors.exposed.headers</param-name>
                  <param-value>XMLHttpRequest</param-value>
                  </init-param>
                <init-param>
                  <param-name>cors.allowSubdomains</param-name>
                  <param-value>true</param-value>
                </init-param>
                <init-param>
                   <param-name>cors.support.credentials</param-name>
                   <param-value>true</param-value>
                </init-param>
                <init-param>
                   <param-name>cors.allowed.headers</param-name>
                   <param-value>Accept, Origin, XMLHttpRequest, X-Requested-With, Access-Control-Request-Headers, Content-Type, Access-Control-Request-Method, Authorization</param-value>
                </init-param>
         <async-supported>true</async-supported>
        </filter>
        <filter-mapping>
                <filter-name>CorsFilter</filter-name>
                <url-pattern>/*</url-pattern>
        </filter-mapping>

Link to comment
Share on other sites

  • Answers 1
  • Created
  • Last Reply

Top Posters For This Question

Top Posters For This Question

1 answer to this question

Recommended Posts

  • 0
On 4/29/2022 at 6:54 PM, bitmonky said:

Hi All, I am Testing with the Free Version (Not Enterprise)

https://antsrv.bitmonky.com:5443/WebRTCApp/pcIndex.html?dur=2&name=s17621-2200-1&wzID=xdxeFeJLTOUIRQBZ

Trying to get it to signal my main applicaton on another server using nodesJS  installed on the same  server as  the antmedia server but on port :13380

Have Tried these configs in my /usr/local/antmedia/webapps/WebRTCApp/WEB-INF/web.xml

Unfortunately none of this seems to have any effect on the server.

        <filter>
                <filter-name>CorsFilter</filter-name>
                <filter-class>io.antmedia.filter.CorsHeaderFilter</filter-class>
               <init-param>
                    <param-name>cors.allowed.origins</param-name>
                    <param-value>https://bitmonky.com:13380</param-value>
                </init-param>
                <init-param>
                        <param-name>cors.allowed.methods</param-name>
                        <param-value>GET,POST,HEAD,OPTIONS,PUT,DELETE</param-value>
                </init-param>
                <init-param>
                  <param-name>cors.exposed.headers</param-name>
                  <param-value>XMLHttpRequest</param-value>
                  </init-param>
                <init-param>
                  <param-name>cors.allowSubdomains</param-name>
                  <param-value>true</param-value>
                </init-param>
                <init-param>
                   <param-name>cors.support.credentials</param-name>
                   <param-value>true</param-value>
                </init-param>
                <init-param>
                   <param-name>cors.allowed.headers</param-name>
                   <param-value>Accept, Origin, XMLHttpRequest, X-Requested-With, Access-Control-Request-Headers, Content-Type, Access-Control-Request-Method, Authorization</param-value>
                </init-param>
         <async-supported>true</async-supported>
        </filter>
        <filter-mapping>
                <filter-name>CorsFilter</filter-name>
                <url-pattern>/*</url-pattern>
        </filter-mapping>

Hi,

How are you?

We have improved the CORS filter use and have tried to make the usage simple.

You can refer to https://stackoverflow.com/a/73282400/16496465 for the same.

 

Also sorry for missing your question. I would like to offer a virtual coffee to you through some Starbucks gift cards to show our empathy and support.

Please let me know about your mail address so that we can send the gift card to you.

Looking forward to hear from you.

 

--

Best Regards,

Mohit Dubey 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share


×
×
  • Create New...