Jump to content
  • 0

rtsp: Protocol not supported


miguel.chillitupa
 Share

Question

Hi,

I've just installed the server (version 2.4.3) and I want to stream and rstp source, so I've added it as a  stream source, but, I'm having this error in the log:

ERROR i.a.streamsource.StreamFetcher - cannot open stream: rtsp://192.168.x.x:8554/ with error:: Protocol not supported

Is there anything I need to do to add rtsp support?

Regards,

Miguel

Link to comment
Share on other sites

5 answers to this question

Recommended Posts

  • 1

Hi @miguel.chillitupa and @Yash

RTSP support is already active by default. I've an idea that may help you. 

I think the problem may be about tcp or udp protocol. You can change the configuration parameter to let the Ant Media Server use UDP. 

- Open the application property file(/usr/local/antmedia/webapps/{APP}/red5-web.properties)  and change RTSP pull type to UDP by adding following property

settings.rtspPullTransportType=udp

- Save the file

- Restart the server and try again

sudo service antmedia restart

If problems resolves, it's great.

If it does not resolve, could you just try to run ffmpeg command for the RTSP source in your server and let us know the output?

 

Regards,

A. Oguz

  • Thanks 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...