Jump to content
  • 0

Problem configuring Subdomain for HTTP and HTTPS for Ant Media Server


Paul
 Share

Question

Sorry if this is more a server config question, but here goes:

I currently have a fresh Ant Media server install (community ed)

this resolves on port

http://myipaddress:5080 - and I can log on etc. 

Ideally I would like this to be on a subdomain on my server


and the secure version

https://sub.domain.com:5443 (with the installed Apps resolving on https://sub.domain.com:5443/WebRTCApp) 

My question is what the Vhosts configuration of my server should look like to support this?  What is the actual root directory of the server? 

I've guessed at this:

DocumentRoot /usr/local/antmedia/webapps

However at present my server returns a permissions error when loading in the browser. Not sure if I need to give permissions to this directory or if I'm pointing it to the completely wrong place.

any advice appreciated. 



        DocumentRoot /usr/local/antmedia/webapps


        ErrorLog ${APACHE_LOG_DIR}/error.log

        CustomLog ${APACHE_LOG_DIR}/access.log combined


        SSLEngine on

        SSLCertificateFile /home/paul/certs/STAR_MYCERT_com.crt

        SSLCertificateKeyFile /home/paul/certs/myCERT_.com.key

        SSLCACertificateFile /home/paul/certs/myCERT_com.ca-bundle




Link to comment
Share on other sites

  • Answers 3
  • Created
  • Last Reply

Top Posters For This Question

Popular Days

Top Posters For This Question

3 answers to this question

Recommended Posts

  • 0
To further clarify. Subdomain resolves ok on the correct port. It just returns a 403 forbidden when the document root is pointed at 

DocumentRoot /usr/local/antmedia/webapps

Is this the right place for a VHosts entry to be pointed, and what permissions should I need for the ant media server to resolve. 



On Sunday, 5 April 2020 21:28:14 UTC+1, Paul wrote:
Sorry if this is more a server config question, but here goes:

I currently have a fresh Ant Media server install (community ed)

this resolves on port

http://myipaddress:5080 - and I can log on etc. 

Ideally I would like this to be on a subdomain on my server


and the secure version

https://sub.domain.com:5443 (with the installed Apps resolving on https://sub.domain.com:5443/WebRTCApp

My question is what the Vhosts configuration of my server should look like to support this?  What is the actual root directory of the server? 

I've guessed at this:

DocumentRoot /usr/local/antmedia/webapps

However at present my server returns a permissions error when loading in the browser. Not sure if I need to give permissions to this directory or if I'm pointing it to the completely wrong place.

any advice appreciated. 



        DocumentRoot /usr/local/antmedia/webapps


        ErrorLog ${APACHE_LOG_DIR}/error.log

        CustomLog ${APACHE_LOG_DIR}/access.log combined


        SSLEngine on

        SSLCertificateFile /home/paul/certs/STAR_MYCERT_com.crt

        SSLCertificateKeyFile /home/paul/certs/myCERT_.com.key

        SSLCACertificateFile /home/paul/certs/myCERT_com.ca-bundle




Link to comment
Share on other sites

  • 0
Yep.- the SSL guide shown in the documentation assumes that I don't already have an SSL wildcard installed, and executing the SSL install script would potentially mess heavily with the existing server configuration.


I think I've managed to work it out. 


<VirtualHost subdomain.domain.com:5443>


       <Directory "/usr/local/antmedia/webapps">

        Options FollowSymLinks

        AllowOverride None

        Require all granted

        </Directory>


</VirtualHost>





The above seemed to be required in my Virtual Hosts file. I am however now getting Java JSP tags printed to the browser - but that is possibly also a server misconfiguration somewhere.

Thank you for your help and responsiveness.



On Sunday, 5 April 2020 22:51:37 UTC+1, Murat Aydin wrote:
Hi Paul,


Best regards,




--
Murat AYDIN
------------------


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share


×
×
  • Create New...