Jump to content
  • 0

Rest api


Sherin Fathima
 Share

Question

  • Answers 9
  • Created
  • Last Reply

Top Posters For This Question

9 answers to this question

Recommended Posts

  • 0

I already tried with this  /v2/broadcasts/create. It always returns 404 error. It is worked with this /rest/request?_path=WebRTCAppEE/rest/v2/broadcasts/create in postman but not worked in my code. I have no idea how do I continue to test.
On Tuesday, April 14, 2020 at 5:24:52 PM UTC+7, mahmut asım Onat wrote:
Hi Sherin,

You can send a post request to  /v2/broadcasts/create create a broadcast using the REST API.
You can check out what to include in the body here: https://antmedia.io/rest/

Best,
Asim
Link to comment
Share on other sites

  • 0
You can take a look at the REST Guide and Reference to get started. 

@may , you can take a look at the some sample test codes in order to see how it works.
check this out -> 

Please also pay attention the value of ROOT_SERVICE_URL
private static final String ROOT_SERVICE_URL = "http://localhost:5080/LiveApp/rest";


Link to comment
Share on other sites

  • 0
Hi May,

Could you also add your IP to WebRTCAppEE settings if you are using the WebRTCAppEE. If you are using LiveApp, the link should have LiveApp instead of WebRTCAppEE like:
yourdomain/LiveApp/rest/v2/broadcasts/create
Please let me know if this solves your problem.

Best,
Asim

On Tuesday, May 5, 2020 at 7:40:41 AM UTC+3, may nyein wrote:
Does it need any authentication to request API? It returns 403 even though I added my ip address in LiveApp application setting.

Link to comment
Share on other sites

  • 0

Hi!

Thank you for the response. I am accessing the api using the static IP attached to the EC2 instance.
I tried enabling the useGlobalIp parameter in the properties, however it still only returns the local ip address instead of the public one.
I also tried changing the rtmp.host property with the static public IP of the EC2, but didn't work.

Here's the response fyr:

 

 

368859874_Screenshot2021-02-26094925.png.768b1be2a2e9201500dbb1c84d1031ca.png

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share


×
×
  • Create New...