Jump to content
  • 0

REST APIs


Reeti Garg
 Share

Question

  • Answers 8
  • Created
  • Last Reply

Top Posters For This Question

8 answers to this question

Recommended Posts

  • 0
Hi Reeti,

There are one IP filters for each created app. The default apps, LiveApp and WebRTCAppEE, have their own filters. Could it be possible that you've set only one of them and trying to access the other app?

Best,
Asim

On Friday, May 15, 2020 at 7:49:42 PM UTC+3, Reeti Garg wrote:
Hi, 

Not able to access Ant media's rest API, even though I added the IP filter as 0.0.0.0/0

Link to comment
Share on other sites

  • 0
Hi, the apps are same. 
For instance, I have added 127.0.0.1,192.168.0.8 as IP Filter on the url https://antmediademo.s2sclasses.com/#/applications/WebRTCAppEE under the settings tab.
I am making the request to https://antmediademo.s2sclasses.com/rest/request?_path=WebRTCAppEE/rest/v2/broadcasts/count from postman and it still returns '403 Forbidden' :(

On Monday, May 18, 2020 at 4:50:02 PM UTC+5:30, mahmut asım Onat wrote:
Hi Reeti,

There are one IP filters for each created app. The default apps, LiveApp and WebRTCAppEE, have their own filters. Could it be possible that you've set only one of them and trying to access the other app?

Best,
Asim

On Friday, May 15, 2020 at 7:49:42 PM UTC+3, Reeti Garg wrote:
Hi, 

Not able to access Ant media's rest API, even though I added the IP filter as 0.0.0.0/0

Link to comment
Share on other sites

  • 0
Hi Reeti,

Could you use the rest api like this?
https://antmediademo.s2sclasses.com/WebRTCAppEE/rest/v2/broadcasts/count

I've checked this link and it works, hope this solves your problem.

Best,
Asim

On Monday, May 18, 2020 at 5:09:11 PM UTC+3, Reeti Garg wrote:
Hi, the apps are same. 
For instance, I have added 127.0.0.1,192.168.0.8 as IP Filter on the url https://antmediademo.s2sclasses.com/#/applications/WebRTCAppEE under the settings tab.
I am making the request to https://antmediademo.s2sclasses.com/rest/request?_path=WebRTCAppEE/rest/v2/broadcasts/count from postman and it still returns '403 Forbidden' :(

On Monday, May 18, 2020 at 4:50:02 PM UTC+5:30, mahmut asım Onat wrote:
Hi Reeti,

There are one IP filters for each created app. The default apps, LiveApp and WebRTCAppEE, have their own filters. Could it be possible that you've set only one of them and trying to access the other app?

Best,
Asim

On Friday, May 15, 2020 at 7:49:42 PM UTC+3, Reeti Garg wrote:
Hi, 

Not able to access Ant media's rest API, even though I added the IP filter as 0.0.0.0/0

Link to comment
Share on other sites

  • 0
Hi, 
For some reason,this seems to work fine with postman (which earlier was not) but I still get CORS error when I make a request from my angular app :(
Please help. 

On Wednesday, May 20, 2020 at 7:28:57 PM UTC+5:30, mahmut asım Onat wrote:
Hi Reeti,

Could you use the rest api like this?
https://antmediademo.s2sclasses.com/WebRTCAppEE/rest/v2/broadcasts/count

I've checked this link and it works, hope this solves your problem.

Best,
Asim

On Monday, May 18, 2020 at 5:09:11 PM UTC+3, Reeti Garg wrote:
Hi, the apps are same. 
For instance, I have added 127.0.0.1,192.168.0.8 as IP Filter on the url https://antmediademo.s2sclasses.com/#/applications/WebRTCAppEE under the settings tab.
I am making the request to https://antmediademo.s2sclasses.com/rest/request?_path=WebRTCAppEE/rest/v2/broadcasts/count from postman and it still returns '403 Forbidden' :(

On Monday, May 18, 2020 at 4:50:02 PM UTC+5:30, mahmut asım Onat wrote:
Hi Reeti,

There are one IP filters for each created app. The default apps, LiveApp and WebRTCAppEE, have their own filters. Could it be possible that you've set only one of them and trying to access the other app?

Best,
Asim

On Friday, May 15, 2020 at 7:49:42 PM UTC+3, Reeti Garg wrote:
Hi, 

Not able to access Ant media's rest API, even though I added the IP filter as 0.0.0.0/0

Link to comment
Share on other sites

  • 0
Hi Reeti,

Have you modified CORS filter settings? By default, it is open for everyone so you shouldn't get such error. 

Best,
Asim

On Wednesday, May 20, 2020 at 7:46:22 PM UTC+3, Reeti Garg wrote:
Hi, 
For some reason,this seems to work fine with postman (which earlier was not) but I still get CORS error when I make a request from my angular app :(
Please help. 

On Wednesday, May 20, 2020 at 7:28:57 PM UTC+5:30, mahmut asım Onat wrote:
Hi Reeti,

Could you use the rest api like this?
https://antmediademo.s2sclasses.com/WebRTCAppEE/rest/v2/broadcasts/count

I've checked this link and it works, hope this solves your problem.

Best,
Asim

On Monday, May 18, 2020 at 5:09:11 PM UTC+3, Reeti Garg wrote:
Hi, the apps are same. 
For instance, I have added 127.0.0.1,192.168.0.8 as IP Filter on the url https://antmediademo.s2sclasses.com/#/applications/WebRTCAppEE under the settings tab.
I am making the request to https://antmediademo.s2sclasses.com/rest/request?_path=WebRTCAppEE/rest/v2/broadcasts/count from postman and it still returns '403 Forbidden' :(

On Monday, May 18, 2020 at 4:50:02 PM UTC+5:30, mahmut asım Onat wrote:
Hi Reeti,

There are one IP filters for each created app. The default apps, LiveApp and WebRTCAppEE, have their own filters. Could it be possible that you've set only one of them and trying to access the other app?

Best,
Asim

On Friday, May 15, 2020 at 7:49:42 PM UTC+3, Reeti Garg wrote:
Hi, 

Not able to access Ant media's rest API, even though I added the IP filter as 0.0.0.0/0

Link to comment
Share on other sites

  • 0
Hi, This is what my CORS Filter is:
<filter>
                <filter-name>CorsFilter</filter-name>
                <filter-class>io.antmedia.filter.CorsHeaderFilter</filter-class>
                <init-param>
                    <param-name>cors.allowed.origins</param-name>
                    <param-value>*</param-value>
                 </init-param>
                 <init-param>
                        <param-name>cors.allowed.methods</param-name>
                        <param-value>GET,POST,HEAD,OPTIONS,PUT,DELETE</param-value>
                 </init-param>
        </filter>

On Thursday, May 21, 2020 at 12:12:52 AM UTC+5:30, mahmut asım Onat wrote:
Hi Reeti,

Have you modified CORS filter settings? By default, it is open for everyone so you shouldn't get such error. 

Best,
Asim

On Wednesday, May 20, 2020 at 7:46:22 PM UTC+3, Reeti Garg wrote:
Hi, 
For some reason,this seems to work fine with postman (which earlier was not) but I still get CORS error when I make a request from my angular app :(
Please help. 

On Wednesday, May 20, 2020 at 7:28:57 PM UTC+5:30, mahmut asım Onat wrote:
Hi Reeti,

Could you use the rest api like this?
https://antmediademo.s2sclasses.com/WebRTCAppEE/rest/v2/broadcasts/count

I've checked this link and it works, hope this solves your problem.

Best,
Asim

On Monday, May 18, 2020 at 5:09:11 PM UTC+3, Reeti Garg wrote:
Hi, the apps are same. 
For instance, I have added 127.0.0.1,192.168.0.8 as IP Filter on the url https://antmediademo.s2sclasses.com/#/applications/WebRTCAppEE under the settings tab.
I am making the request to https://antmediademo.s2sclasses.com/rest/request?_path=WebRTCAppEE/rest/v2/broadcasts/count from postman and it still returns '403 Forbidden' :(

On Monday, May 18, 2020 at 4:50:02 PM UTC+5:30, mahmut asım Onat wrote:
Hi Reeti,

There are one IP filters for each created app. The default apps, LiveApp and WebRTCAppEE, have their own filters. Could it be possible that you've set only one of them and trying to access the other app?

Best,
Asim

On Friday, May 15, 2020 at 7:49:42 PM UTC+3, Reeti Garg wrote:
Hi, 

Not able to access Ant media's rest API, even though I added the IP filter as 0.0.0.0/0

Link to comment
Share on other sites

  • 0
Hi Reeti,

Your filter allows every request so I think the problem is angular since I can't really think of any other setting that would lead to this behavior on the server-side.

Best,
Asim

On Thursday, May 21, 2020 at 10:29:50 AM UTC+3, Reeti Garg wrote:
Hi, This is what my CORS Filter is:
<filter>
                <filter-name>CorsFilter</filter-name>
                <filter-class>io.antmedia.filter.CorsHeaderFilter</filter-class>
                <init-param>
                    <param-name>cors.allowed.origins</param-name>
                    <param-value>*</param-value>
                 </init-param>
                 <init-param>
                        <param-name>cors.allowed.methods</param-name>
                        <param-value>GET,POST,HEAD,OPTIONS,PUT,DELETE</param-value>
                 </init-param>
        </filter>

On Thursday, May 21, 2020 at 12:12:52 AM UTC+5:30, mahmut asım Onat wrote:
Hi Reeti,

Have you modified CORS filter settings? By default, it is open for everyone so you shouldn't get such error. 

Best,
Asim

On Wednesday, May 20, 2020 at 7:46:22 PM UTC+3, Reeti Garg wrote:
Hi, 
For some reason,this seems to work fine with postman (which earlier was not) but I still get CORS error when I make a request from my angular app :(
Please help. 

On Wednesday, May 20, 2020 at 7:28:57 PM UTC+5:30, mahmut asım Onat wrote:
Hi Reeti,

Could you use the rest api like this?
https://antmediademo.s2sclasses.com/WebRTCAppEE/rest/v2/broadcasts/count

I've checked this link and it works, hope this solves your problem.

Best,
Asim

On Monday, May 18, 2020 at 5:09:11 PM UTC+3, Reeti Garg wrote:
Hi, the apps are same. 
For instance, I have added 127.0.0.1,192.168.0.8 as IP Filter on the url https://antmediademo.s2sclasses.com/#/applications/WebRTCAppEE under the settings tab.
I am making the request to https://antmediademo.s2sclasses.com/rest/request?_path=WebRTCAppEE/rest/v2/broadcasts/count from postman and it still returns '403 Forbidden' :(

On Monday, May 18, 2020 at 4:50:02 PM UTC+5:30, mahmut asım Onat wrote:
Hi Reeti,

There are one IP filters for each created app. The default apps, LiveApp and WebRTCAppEE, have their own filters. Could it be possible that you've set only one of them and trying to access the other app?

Best,
Asim

On Friday, May 15, 2020 at 7:49:42 PM UTC+3, Reeti Garg wrote:
Hi, 

Not able to access Ant media's rest API, even though I added the IP filter as 0.0.0.0/0

Link to comment
Share on other sites

  • 0
Hi,

I have a similar problem but when i replace * with the single URL in cors.allowed.origins it works. else it doesn't work. 
even if we put multiple URLs its not working.

Thanks


On Thursday, May 21, 2020 at 7:37:47 PM UTC+5:30, mahmut asım Onat wrote:
Hi Reeti,

Your filter allows every request so I think the problem is angular since I can't really think of any other setting that would lead to this behavior on the server-side.

Best,
Asim

On Thursday, May 21, 2020 at 10:29:50 AM UTC+3, Reeti Garg wrote:
Hi, This is what my CORS Filter is:
<filter>
                <filter-name>CorsFilter</filter-name>
                <filter-class>io.antmedia.filter.CorsHeaderFilter</filter-class>
                <init-param>
                    <param-name>cors.allowed.origins</param-name>
                    <param-value>*</param-value>
                 </init-param>
                 <init-param>
                        <param-name>cors.allowed.methods</param-name>
                        <param-value>GET,POST,HEAD,OPTIONS,PUT,DELETE</param-value>
                 </init-param>
        </filter>

On Thursday, May 21, 2020 at 12:12:52 AM UTC+5:30, mahmut asım Onat wrote:
Hi Reeti,

Have you modified CORS filter settings? By default, it is open for everyone so you shouldn't get such error. 

Best,
Asim

On Wednesday, May 20, 2020 at 7:46:22 PM UTC+3, Reeti Garg wrote:
Hi, 
For some reason,this seems to work fine with postman (which earlier was not) but I still get CORS error when I make a request from my angular app :(
Please help. 

On Wednesday, May 20, 2020 at 7:28:57 PM UTC+5:30, mahmut asım Onat wrote:
Hi Reeti,

Could you use the rest api like this?
https://antmediademo.s2sclasses.com/WebRTCAppEE/rest/v2/broadcasts/count

I've checked this link and it works, hope this solves your problem.

Best,
Asim

On Monday, May 18, 2020 at 5:09:11 PM UTC+3, Reeti Garg wrote:
Hi, the apps are same. 
For instance, I have added 127.0.0.1,192.168.0.8 as IP Filter on the url https://antmediademo.s2sclasses.com/#/applications/WebRTCAppEE under the settings tab.
I am making the request to https://antmediademo.s2sclasses.com/rest/request?_path=WebRTCAppEE/rest/v2/broadcasts/count from postman and it still returns '403 Forbidden' :(

On Monday, May 18, 2020 at 4:50:02 PM UTC+5:30, mahmut asım Onat wrote:
Hi Reeti,

There are one IP filters for each created app. The default apps, LiveApp and WebRTCAppEE, have their own filters. Could it be possible that you've set only one of them and trying to access the other app?

Best,
Asim

On Friday, May 15, 2020 at 7:49:42 PM UTC+3, Reeti Garg wrote:
Hi, 

Not able to access Ant media's rest API, even though I added the IP filter as 0.0.0.0/0

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...