Jump to content
  • 0

WebRTC does not play via Edge server


Pavel Tsukanov
 Share

Question

Hi


I configured a cluster with origin and edge server
I published via origin server https://{origin_domain}:5443/WebRTCAppEE/  (using the latest chrome browser)

and I am trying to play on edge server (using the latest chrome browser)
but i see black player with the waiter
However i could play HLS via edge

also i do not see any error in server log

I see a lot of

.....
2020-06-08 11:55:51,434 [vert.x-eventloop-thread-6] INFO  i.a.enterprise.webrtc.WebRTCAdaptor - Client:848999147 for stream cpp_private current video bitrate: 1200000 audio bitrate: 96000 webrtc client target bitrate: 300000
2020-06-08 11:55:55,512 [vert.x-eventloop-thread-5] INFO  i.a.enterprise.webrtc.WebRTCAdaptor - get number of viewers for stream id cpp_private is 1
2020-06-08 11:55:56,429 [network_thread - 5185] INFO  org.webrtc.Logging - Tag:WebRtcAudioTrackExternal - Message:GetPlayoutUnderrunCount
.....
Looks like packets are delivered to client


Any idea?


Thank you
Pavel
Link to comment
Share on other sites

  • Answers 8
  • Created
  • Last Reply

Top Posters For This Question

Top Posters For This Question

8 answers to this question

Recommended Posts

  • 0
Yeah you're right. Thank you for reporting.

It's resolved in 2.1.0-SNAPSHOT and it'll be released later this month.

On Monday, June 8, 2020 at 3:16:42 PM UTC+3, Pavel Tsukanov wrote:
I uses Ant Enterprise Edition 2.0 for origin and edge servers
Link to comment
Share on other sites

  • 0
I was able to play WebRTC. origin and edge was in single amazon subnet.  I allowed all traffic in the subnet between servers and WebRTC started to work.  Looks like something is wrong with setting of Ant default security group (which was created during installing Ant from AWS marketplace). Do you have more info about it?

On Monday, June 8, 2020 at 8:41:27 PM UTC+3, ahmet oguz mermerkaya wrote:
Yeah you're right. Thank you for reporting.

It's resolved in 2.1.0-SNAPSHOT and it'll be released later this month.

On Monday, June 8, 2020 at 3:16:42 PM UTC+3, Pavel Tsukanov wrote:
I uses Ant Enterprise Edition 2.0 for origin and edge servers
Link to comment
Share on other sites

  • 0
In cluster mode, TCP ports should be opened between origin and edge groups. 

In default-security group, TCP ports are not open by default. It should be opened in installing a cluster. 

Thank you for reporting the issue you're having. Because I think we should do something to make this process easier.

Do you have any idea about that?
  

Link to comment
Share on other sites

  • 0
I see 2 ways for now
1. Log file must have errors that ports are closed. I did not see this error in logs
2. May be separate adding server to cluster as edge and origin and when you add an edge server to cluster try to check if origin servers are available and show warning with problems
 i.e. sudo ./change_server_mode.sh cluster <MONGODB_SERVER_IP>
change to
sudo ./change_server_mode.sh edge <MONGODB_SERVER_IP> - check edge configuration
sudo ./change_server_mode.sh origin <MONGODB_SERVER_IP> - check origin configuration

By the way
I found undocument value in change_server_mode.sh - USE_GLOBAL_IP - the value works for me. My servers are in different regions in amazon and using this key helped me to connect origin and edge servers in different regions.
Looks like i should not use this way, i think there is another way to connect the servers  via internal network (i have not seen this way yet). but USE_GLOBAL_IP  saved me time.

PS. I have created a prototype for one way live video chatting using Ant. if the prototype will be approved then we will install at least 10 Enterprise instances.




On Tuesday, June 9, 2020 at 9:30:02 AM UTC+3, ahmet oguz mermerkaya wrote:
In cluster mode, TCP ports should be opened between origin and edge groups. 

In default-security group, TCP ports are not open by default. It should be opened in installing a cluster. 

Thank you for reporting the issue you're having. Because I think we should do something to make this process easier.

Do you have any idea about that?
  

Link to comment
Share on other sites

  • 0
Hi Pavel Tsukanov,

can you check and send us what error you get from the console of developer tools in the chrome browser when trying to play webrtc?  Did you open all ports needed:

And did you configure the server according this wiki?

Best Regards,
Can

PS: Free or Paid one-on-one support and consultancy for your streaming project, please book at https://calendly.com/antmedia/

On Mon, 8 Jun at 10:29 PM , Pavel Tsukanov <cpp.myjob@gmail.com> wrote:
I was able to play WebRTC. origin and edge was in single amazon subnet.  I allowed all traffic in the subnet between servers and WebRTC started to work.  Looks like something is wrong with setting of Ant default security group (which was created during installing Ant from AWS marketplace). Do you have more info about it?

On Monday, June 8, 2020 at 8:41:27 PM UTC+3, ahmet oguz mermerkaya wrote:
Yeah you're right. Thank you for reporting.

It's resolved in 2.1.0-SNAPSHOT and it'll be released later this month.

On Monday, June 8, 2020 at 3:16:42 PM UTC+3, Pavel Tsukanov wrote:
I uses Ant Enterprise Edition 2.0 for origin and edge servers
--
You received this message because you are subscribed to the Google Groups "Ant Media Server" group.
To unsubscribe from this group and stop receiving emails from it, send an email to ant-media-server+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/ant-media-server/045222c2-c7a9-4ea7-b108-39876864ba2bo%40googlegroups.com.
8243:1264838
Link to comment
Share on other sites

  • 0
I already fixed my problem See my answer above

On Tuesday, June 9, 2020 at 3:47:32 PM UTC+3, Ant Media wrote:
Hi Pavel Tsukanov,

can you check and send us what error you get from the console of developer tools in the chrome browser when trying to play webrtc?  Did you open all ports needed:

And did you configure the server according this wiki?

Best Regards,
Can

PS: Free or Paid one-on-one support and consultancy for your streaming project, please book at https://calendly.com/antmedia/

On Mon, 8 Jun at 10:29 PM
, Pavel Tsukanov <
> wrote:
I was able to play WebRTC. origin and edge was in single amazon subnet.  I allowed all traffic in the subnet between servers and WebRTC started to work.  Looks like something is wrong with setting of Ant default security group (which was created during installing Ant from AWS marketplace). Do you have more info about it?


On Monday, June 8, 2020 at 8:41:27 PM UTC+3, ahmet oguz mermerkaya wrote:
Yeah you're right. Thank you for reporting.

It's resolved in 2.1.0-SNAPSHOT and it'll be released later this month.


On Monday, June 8, 2020 at 3:16:42 PM UTC+3, Pavel Tsukanov wrote:
I uses Ant Enterprise Edition 2.0 for origin and edge servers

--
You received this message because you are subscribed to the Google Groups "Ant Media Server" group.
To unsubscribe from this group and stop receiving emails from it, send an email to ant-medi...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/ant-media-server/045222c2-c7a9-4ea7-b108-39876864ba2bo%40googlegroups.com.
8243:1264838
Link to comment
Share on other sites

  • 0
Hi Pavel Tsukanov,
 Looks like something is wrong with setting of Ant default security group (which was created during installing Ant from AWS marketplace) 

ok I did not receive this part of the ticket. Thank you for reporting this. I will forward this to our system administrator responsible for AWS.
Maybe these ports were not open in the security group because it is not directly configure for cluster mode:
TCP:5000-65000 (You need to open this range in only cluster mode for internal network. It should not be open to public. 

Best Regards,
Can



PS: Free or Paid one-on-one support and consultancy for your streaming project, please book at https://calendly.com/antmedia/

On Wed, 10 Jun at 1:31 PM , Pavel Tsukanov <cpp.myjob@gmail.com> wrote:
I already fixed my problem See my answer above

On Tuesday, June 9, 2020 at 3:47:32 PM UTC+3, Ant Media wrote:
Hi Pavel Tsukanov,

can you check and send us what error you get from the console of developer tools in the chrome browser when trying to play webrtc?  Did you open all ports needed:

And did you configure the server according this wiki?

Best Regards,
Can

PS: Free or Paid one-on-one support and consultancy for your streaming project, please book at https://calendly.com/antmedia/

On Mon, 8 Jun at 10:29 PM
, Pavel Tsukanov <
> wrote:
I was able to play WebRTC. origin and edge was in single amazon subnet.  I allowed all traffic in the subnet between servers and WebRTC started to work.  Looks like something is wrong with setting of Ant default security group (which was created during installing Ant from AWS marketplace). Do you have more info about it?


On Monday, June 8, 2020 at 8:41:27 PM UTC+3, ahmet oguz mermerkaya wrote:
Yeah you're right. Thank you for reporting.

It's resolved in 2.1.0-SNAPSHOT and it'll be released later this month.


On Monday, June 8, 2020 at 3:16:42 PM UTC+3, Pavel Tsukanov wrote:
I uses Ant Enterprise Edition 2.0 for origin and edge servers

--
You received this message because you are subscribed to the Google Groups "Ant Media Server" group.
To unsubscribe from this group and stop receiving emails from it, send an email to ant-medi...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/ant-media-server/045222c2-c7a9-4ea7-b108-39876864ba2bo%40googlegroups.com.
--
You received this message because you are subscribed to the Google Groups "Ant Media Server" group.
To unsubscribe from this group and stop receiving emails from it, send an email to ant-media-server+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/ant-media-server/e6e6c233-dc59-4c21-ac64-6f6a1fcb9bcco%40googlegroups.com.
8243:1264838
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share


×
×
  • Create New...