Jump to content
  • 0

"Settings could not be saved" message for LiveApp settings


Ramil Garaev
 Share

Question

Hello AntMedia team!

I use the Enterprise version bought on the AWS marketplace. 
I try to change settings via the management dashboard. For LiveApp I can't change anything. Every time I try to change something  I see a "Settings could not be saved" message. 
For WebRTCAppEE I can change settings successfully. 

I tried to restart AMS but I didn't help. 
Also, I cant get logs from HTTP API. 
Link to comment
Share on other sites

  • Answers 4
  • Created
  • Last Reply

Top Posters For This Question

Popular Days

Top Posters For This Question

4 answers to this question

Recommended Posts

  • 0
Hi Ramil,

We encounter this issue if red5-web.properties file's owner has changed from antmedia to root or something else. 

1. Please go to /usr/local/antmedia/webapps/LiveApp/WEB-INF
2. type "ls -l"
3. Make sure that your red5-web.properties owner is antmedia and it has permission to write. 

Check also the permissions for the logs directory and files under logs folder. 

Regards,
A. Oguz

On Wednesday, July 22, 2020 at 10:03:26 AM UTC+3, Ramil Garaev wrote:
Hello AntMedia team!

I use the Enterprise version bought on the AWS marketplace. 
I try to change settings via the management dashboard. For LiveApp I can't change anything. Every time I try to change something  I see a "Settings could not be saved" message. 
For WebRTCAppEE I can change settings successfully. 

I tried to restart AMS but I didn't help. 
Also, I cant get logs from HTTP API. 
Link to comment
Share on other sites

  • 0
Thank you for the fast response, Ahmet!

It's true I changed owner for writing in red5-web.properties

"ls -l " command returns 
"drwxrwxr-x 3 ubuntu ubuntu 4096 May  4 17:28 classes
-rw-rw-r-- 1 ubuntu ubuntu 1695 Jul 22 06:45 red5-web.properties
-rw-rw-r-- 1 ubuntu ubuntu 3315 Jul  5 17:59 red5-web.xml
-rw-rw-r-- 1 ubuntu ubuntu 5165 May  4 17:48 web.xml"

I am an absolute noob in the command line. Could you say please what command changes the owner to antmedia? 

среда, 22 июля 2020 г., 10:14:35 UTC+3 пользователь ahmet oguz mermerkaya написал:
Hi Ramil,

We encounter this issue if red5-web.properties file's owner has changed from antmedia to root or something else. 

1. Please go to /usr/local/antmedia/webapps/LiveApp/WEB-INF
2. type "ls -l"
3. Make sure that your red5-web.properties owner is antmedia and it has permission to write. 

Check also the permissions for the logs directory and files under logs folder. 

Regards,
A. Oguz

On Wednesday, July 22, 2020 at 10:03:26 AM UTC+3, Ramil Garaev wrote:
Hello AntMedia team!

I use the Enterprise version bought on the AWS marketplace. 
I try to change settings via the management dashboard. For LiveApp I can't change anything. Every time I try to change something  I see a "Settings could not be saved" message. 
For WebRTCAppEE I can change settings successfully. 

I tried to restart AMS but I didn't help. 
Also, I cant get logs from HTTP API. 
Link to comment
Share on other sites

  • 0
I solved the problem. 

Thanks!

среда, 22 июля 2020 г., 10:23:15 UTC+3 пользователь Ramil Garaev написал:
Thank you for the fast response, Ahmet!

It's true I changed owner for writing in red5-web.properties

"ls -l " command returns 
"drwxrwxr-x 3 ubuntu ubuntu 4096 May  4 17:28 classes
-rw-rw-r-- 1 ubuntu ubuntu 1695 Jul 22 06:45 red5-web.properties
-rw-rw-r-- 1 ubuntu ubuntu 3315 Jul  5 17:59 red5-web.xml
-rw-rw-r-- 1 ubuntu ubuntu 5165 May  4 17:48 web.xml"

I am an absolute noob in the command line. Could you say please what command changes the owner to antmedia? 

среда, 22 июля 2020 г., 10:14:35 UTC+3 пользователь ahmet oguz mermerkaya написал:
Hi Ramil,

We encounter this issue if red5-web.properties file's owner has changed from antmedia to root or something else. 

1. Please go to /usr/local/antmedia/webapps/LiveApp/WEB-INF
2. type "ls -l"
3. Make sure that your red5-web.properties owner is antmedia and it has permission to write. 

Check also the permissions for the logs directory and files under logs folder. 

Regards,
A. Oguz

On Wednesday, July 22, 2020 at 10:03:26 AM UTC+3, Ramil Garaev wrote:
Hello AntMedia team!

I use the Enterprise version bought on the AWS marketplace. 
I try to change settings via the management dashboard. For LiveApp I can't change anything. Every time I try to change something  I see a "Settings could not be saved" message. 
For WebRTCAppEE I can change settings successfully. 

I tried to restart AMS but I didn't help. 
Also, I cant get logs from HTTP API. 
Link to comment
Share on other sites

  • 0
It's a pleasure for us. 

Thank you

On Wednesday, July 22, 2020 at 10:31:54 AM UTC+3, Ramil Garaev wrote:
I solved the problem. 

Thanks!

среда, 22 июля 2020 г., 10:23:15 UTC+3 пользователь Ramil Garaev написал:
Thank you for the fast response, Ahmet!

It's true I changed owner for writing in red5-web.properties

"ls -l " command returns 
"drwxrwxr-x 3 ubuntu ubuntu 4096 May  4 17:28 classes
-rw-rw-r-- 1 ubuntu ubuntu 1695 Jul 22 06:45 red5-web.properties
-rw-rw-r-- 1 ubuntu ubuntu 3315 Jul  5 17:59 red5-web.xml
-rw-rw-r-- 1 ubuntu ubuntu 5165 May  4 17:48 web.xml"

I am an absolute noob in the command line. Could you say please what command changes the owner to antmedia? 

среда, 22 июля 2020 г., 10:14:35 UTC+3 пользователь ahmet oguz mermerkaya написал:
Hi Ramil,

We encounter this issue if red5-web.properties file's owner has changed from antmedia to root or something else. 

1. Please go to /usr/local/antmedia/webapps/LiveApp/WEB-INF
2. type "ls -l"
3. Make sure that your red5-web.properties owner is antmedia and it has permission to write. 

Check also the permissions for the logs directory and files under logs folder. 

Regards,
A. Oguz

On Wednesday, July 22, 2020 at 10:03:26 AM UTC+3, Ramil Garaev wrote:
Hello AntMedia team!

I use the Enterprise version bought on the AWS marketplace. 
I try to change settings via the management dashboard. For LiveApp I can't change anything. Every time I try to change something  I see a "Settings could not be saved" message. 
For WebRTCAppEE I can change settings successfully. 

I tried to restart AMS but I didn't help. 
Also, I cant get logs from HTTP API. 
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share


×
×
  • Create New...