Jump to content
  • 0

Embedded videos are always muted by default


Kent
 Share

Question

### Short description

Using the url:  https://stream.mydomain.com/LiveApp/play.html?name=491000748110617606695412

The video is always 'muted' by default.  How can I get it to be unmuted by default ?


Note: I've tested with the WebRTCApp also and it's always muted by default.  Tested on multiple browsers - inside and outside our network.
 


### Environment

* Operating system and version: Debian 10
* Java version: 
* Ant Media Server version:
* Browser name and version: Safari, Firefox, Edge, Chrome, iOS

### Steps to reproduce
1. New installation of Ant Media Server 2.1.0
2. Upload a video
3. Add video and then plan

### Expected behavior
I want the video to be unmuted by default

### Actual behavior
The video always starts muted


Link to comment
Share on other sites

  • Answers 4
  • Created
  • Last Reply

Top Posters For This Question

Top Posters For This Question

4 answers to this question

Recommended Posts

  • 0
Hi Kent,

We added a "muted" parameter for the browser's policy rule. Some browsers are doesn't play automatically with sound. You can remove "muted" parameter in /usr/local/antmedia/webapps/<Application-Name>/play.html page video tag. But I don't recommend removing it.

Check also:

Best Regards,
Selim

On Sunday, August 9, 2020 at 12:43:35 AM UTC+3, Kent wrote:
### Short description


The video is always 'muted' by default.  How can I get it to be unmuted by default ?


Note: I've tested with the WebRTCApp also and it's always muted by default.  Tested on multiple browsers - inside and outside our network.
 


### Environment

* Operating system and version: Debian 10
* Java version: 
* Ant Media Server version:
* Browser name and version: Safari, Firefox, Edge, Chrome, iOS

### Steps to reproduce
1. New installation of Ant Media Server 2.1.0
2. Upload a video
3. Add video and then plan

### Expected behavior
I want the video to be unmuted by default

### Actual behavior
The video always starts muted


Link to comment
Share on other sites

  • 0
Hi Selim,

Thanks for this - couple of followup questions:

1) I don't want them to autoplay - only if the user actually clicks play.   Should we use one of the other play_...  options instead ?

2) My browser is showing the following errors:
> [Error] Failed to load resource: the server responded with a status of 404 () (491000748110617606695412_adaptive.m3u8, line 0)
> [Error] Failed to load resource: the server responded with a status of 404 () (491000748110617606695412.m3u8, line 0)
> [Error] Failed to load resource: the server responded with a status of 404 () (491000748110617606695412.png, line 0)
> [Error] Unhandled Promise Rejection: NotAllowedError: The request is not allowed by the user agent or the platform in the current context, possibly because the user denied permission.

  2a. The .png appears to be a preview - is this automatic or do we need to load a preview ourselves ?
  2b. Do I need to worry about the others ?

Thanks
Kent.




On Sunday, 9 August 2020 11:35:25 UTC+12, Selim Emre wrote:
Hi Kent,

We added a "muted" parameter for the browser's policy rule. Some browsers are doesn't play automatically with sound. You can remove "muted" parameter in /usr/local/antmedia/webapps/<Application-Name>/play.html page video tag. But I don't recommend removing it.

Check also:

Best Regards,
Selim

On Sunday, August 9, 2020 at 12:43:35 AM UTC+3, Kent wrote:
### Short description


The video is always 'muted' by default.  How can I get it to be unmuted by default ?


Note: I've tested with the WebRTCApp also and it's always muted by default.  Tested on multiple browsers - inside and outside our network.
 


### Environment

* Operating system and version: Debian 10
* Java version: 
* Ant Media Server version:
* Browser name and version: Safari, Firefox, Edge, Chrome, iOS

### Steps to reproduce
1. New installation of Ant Media Server 2.1.0
2. Upload a video
3. Add video and then plan

### Expected behavior
I want the video to be unmuted by default

### Actual behavior
The video always starts muted


Link to comment
Share on other sites

  • 0
Okay - I see I can pass  &autoplay=false in the url,  which will disable the autoplay.

But it appears it's still muted by default anyway.

So, disabling autoplay and muted,  will mean the video doesn't play by default (and isn't muted by default in my quick testing).

Kent.


On Monday, 10 August 2020 16:18:34 UTC+12, Kent wrote:
Hi Selim,

Thanks for this - couple of followup questions:

1) I don't want them to autoplay - only if the user actually clicks play.   Should we use one of the other play_...  options instead ?

2) My browser is showing the following errors:
> [Error] Failed to load resource: the server responded with a status of 404 () (491000748110617606695412_adaptive.m3u8, line 0)
> [Error] Failed to load resource: the server responded with a status of 404 () (491000748110617606695412.m3u8, line 0)
> [Error] Failed to load resource: the server responded with a status of 404 () (491000748110617606695412.png, line 0)
> [Error] Unhandled Promise Rejection: NotAllowedError: The request is not allowed by the user agent or the platform in the current context, possibly because the user denied permission.

  2a. The .png appears to be a preview - is this automatic or do we need to load a preview ourselves ?
  2b. Do I need to worry about the others ?

Thanks
Kent.




On Sunday, 9 August 2020 11:35:25 UTC+12, Selim Emre wrote:
Hi Kent,

We added a "muted" parameter for the browser's policy rule. Some browsers are doesn't play automatically with sound. You can remove "muted" parameter in /usr/local/antmedia/webapps/<Application-Name>/play.html page video tag. But I don't recommend removing it.

Check also:

Best Regards,
Selim

On Sunday, August 9, 2020 at 12:43:35 AM UTC+3, Kent wrote:
### Short description


The video is always 'muted' by default.  How can I get it to be unmuted by default ?


Note: I've tested with the WebRTCApp also and it's always muted by default.  Tested on multiple browsers - inside and outside our network.
 


### Environment

* Operating system and version: Debian 10
* Java version: 
* Ant Media Server version:
* Browser name and version: Safari, Firefox, Edge, Chrome, iOS

### Steps to reproduce
1. New installation of Ant Media Server 2.1.0
2. Upload a video
3. Add video and then plan

### Expected behavior
I want the video to be unmuted by default

### Actual behavior
The video always starts muted


Link to comment
Share on other sites

  • 0
Hi Kent,

Have a good day. 

You can remove "muted" parameter in video tag manually. Here is play.html location -> /usr/local/antmedia/webapps/<Application-Name>/play.html

2) My browser is showing the following errors:
These are not real errors. These are just a notification. 

> [Error] Unhandled Promise Rejection: NotAllowedError: The request is not allowed by the user agent or the platform in the current context, possibly because the user denied permission.
This error related to the browser. Please check this answer -> https://stackoverflow.com/questions/49552005/playing-video-automatically-on-safari-wont-work

2a. The .png appears to be a preview - is this automatic or do we need to load a preview ourselves ?

I hope, I could help you.

Best Regards,
Selim

On Monday, August 10, 2020 at 7:45:21 AM UTC+3, Kent wrote:
Okay - I see I can pass  &autoplay=false in the url,  which will disable the autoplay.

But it appears it's still muted by default anyway.

So, disabling autoplay and muted,  will mean the video doesn't play by default (and isn't muted by default in my quick testing).

Kent.


On Monday, 10 August 2020 16:18:34 UTC+12, Kent wrote:
Hi Selim,

Thanks for this - couple of followup questions:

1) I don't want them to autoplay - only if the user actually clicks play.   Should we use one of the other play_...  options instead ?

2) My browser is showing the following errors:
> [Error] Failed to load resource: the server responded with a status of 404 () (491000748110617606695412_adaptive.m3u8, line 0)
> [Error] Failed to load resource: the server responded with a status of 404 () (491000748110617606695412.m3u8, line 0)
> [Error] Failed to load resource: the server responded with a status of 404 () (491000748110617606695412.png, line 0)
> [Error] Unhandled Promise Rejection: NotAllowedError: The request is not allowed by the user agent or the platform in the current context, possibly because the user denied permission.

  2a. The .png appears to be a preview - is this automatic or do we need to load a preview ourselves ?
  2b. Do I need to worry about the others ?

Thanks
Kent.




On Sunday, 9 August 2020 11:35:25 UTC+12, Selim Emre wrote:
Hi Kent,

We added a "muted" parameter for the browser's policy rule. Some browsers are doesn't play automatically with sound. You can remove "muted" parameter in /usr/local/antmedia/webapps/<Application-Name>/play.html page video tag. But I don't recommend removing it.

Check also:

Best Regards,
Selim

On Sunday, August 9, 2020 at 12:43:35 AM UTC+3, Kent wrote:
### Short description


The video is always 'muted' by default.  How can I get it to be unmuted by default ?


Note: I've tested with the WebRTCApp also and it's always muted by default.  Tested on multiple browsers - inside and outside our network.
 


### Environment

* Operating system and version: Debian 10
* Java version: 
* Ant Media Server version:
* Browser name and version: Safari, Firefox, Edge, Chrome, iOS

### Steps to reproduce
1. New installation of Ant Media Server 2.1.0
2. Upload a video
3. Add video and then plan

### Expected behavior
I want the video to be unmuted by default

### Actual behavior
The video always starts muted


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share


×
×
  • Create New...