Jump to content
  • 0

Some RTMP connections not accepted suddenly


Alex O
 Share

Question

I'm having a strange issue all of a sudden. My AMS is used to take RTMP input from users' external OBS setup. This works fine most of the time, but I've found over the past couple weeks that some people are having issues connecting to me in this way. One user tried to connect with RTMP, which shows up as 'Broadcasting' in AMS but then disappears. On the user's side, it shows that he is connecting and disconnecting.

We also use Castr to restream to other services, so we use that to send the main stream back to our AMS so that it can be forwarded to our website. Although this was working fine, it now seems to suffer the same issue as above, yet there is no 'Broadcasting' message at all this time. On both occasions, I can see in the logs that a connection attempt is being made, but I can't make sense of the logs to figure out why.

On looking at issues that may be similar, some people claim that they haven't got port forwarding working. Since most people connect to us with RTMP fine, and no changes have been made to our firewall or system, I don't see how this could be possible. Saying that, what is the full list of ports that need to be open on AMS to accept RTMP connections? It goes without saying that port 1935 is open, since others can connect just fine.

Also, I've tried to test the stream keys with other people and they work, so really unsure what's happening here.


### Short description
__Brief description of what happened__
1 user and 1 restream server unable to connect to AMS via RTMP. One user connects but is immediately disconnected, and the restream server doesn't even connect.


### Environment
Deployed on own hardware

* Operating system and version: Ubuntu 18.04
* Java version: openjdk version "11.0.8"
* Ant Media Server version: Community Edition 2.1.0 20200720_1340
* Browser name and version: Any?

### Steps to reproduce
1. Create new stream key
2. Have user/restream service try to send to RTMP with stream key
3. Either connects then disconnects a few seconds after, or doesn't connect at all.

### Expected behavior
__Put as much detail here as possible__
RTMP link accepted and remains broadcasting

### Actual behavior
__Put as much detail here as possible__
Either connects then disconnects a few seconds after, or doesn't connect at all.
 
### Logs
(DEBUG)

Link to comment
Share on other sites

  • Answers 1
  • Created
  • Last Reply

Top Posters For This Question

Top Posters For This Question

1 answer to this question

Recommended Posts

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share


×
×
  • Create New...