Jump to content
  • 0

WebRTC: ICE failed, add a TURN server and see about:webrtc for more details


Carlo
 Share

Question

Good day,

I am now getting the following error when trying to stream "WebRTC: ICE failed, add a TURN server and see about:webrtc for more details". No code updates or server updates have been applied and this was working fine a couple of days ago. Already tried by restarting/rebooting AMS but still same behavior.

Please advise and thank you in advance.

Enterprise Edition 1.7.2 20190602_1617

Link to comment
Share on other sites

  • Answers 4
  • Created
  • Last Reply

Top Posters For This Question

Top Posters For This Question

4 answers to this question

Recommended Posts

  • 0

HI ! I am also facing the same problem . In javascript sdk when I click on start publishing, I can't successfully publish the video. It shows:

stream id in init peer connection: stream1 close stream id: stream1 
which comes from 
this.initPeerConnection = function(streamId, dataChannelMode) {
if (thiz.remotePeerConnection[streamId] == null)
{
var closedStreamId = streamId;
console.log("stream id in init peer connection: " + streamId + " close stream id: " + closedStreamId);

I did not change any code , it was working fine till a couple of days back. But suddenly this problem started creeping in and now it's not working at all.

Link to comment
Share on other sites

  • 0

Same here - I got an email back from support who suggested this 

I attempted method 2 but it did not work. I'm not 100% sure on how to accomplish method 1. 

Let me first explain it then offer a solution for you.
We use google stun server in our product to receive public ice candidates. But nowadays, sometimes it doesn't provide them as it should. We have two solutions for this. In short term I recommend second one. Here they are:

1. Ant Media Server uses Google Stun Server:

stun:stun.l.google.com:19302

You can change it from /usr/local/antmedia/webapps/APP_NAME/WEB-INF/red5-web.properties with this setting:

settings.webrtc.stunServerURI

2. For public IP candidates please edit the following line in /usr/local/antmedia/conf/red5.properties

server.name=SERVER_PUBLIC_IP_ADDRESS

Please add the following line

settings.replaceCandidateAddrWithServerAddr=true

into the following file

/usr/local/antmedia/webapps/APP_NAME/WEB-INF/red5-web.properties

and restart the server.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share


×
×
  • Create New...