Jump to content
  • 0

getting publishTimeoutError while trying to publish localstream


Divyanshu Kalra
 Share

Question

  • Answers 3
  • Created
  • Last Reply

Top Posters For This Question

Top Posters For This Question

3 answers to this question

Recommended Posts

  • 0

Hi there,

I'm just a guest,

 

You can check your source code and update ice server like as below:

 

var pc_config = {
'iceServers' : [ {
'urls' : 'stun:stun1.l.google.com:19302'
} ]
};

 

 

Solution 2:

Please add the following line

settings.webrtc.stunServerURI=stun:stun1.l.google.com:19302

into the following file

/usr/local/antmedia/webapps/APP_NAME/WEB-INF/red5-web.properties

and restart the server.

Solution 3:

Please edit the following line in

/usr/local/antmedia/conf/red5.properties

server.name=SERVER_PUBLIC_IP_ADDRESS

Please add the following line

settings.replaceCandidateAddrWithServerAddr=true

into the following file

/usr/local/antmedia/webapps/APP_NAME/WEB-INF/red5-web.properties

and restart the server

Solution 4:

You can install your own TURN server and use it as a STUN server.

You can look this document to install TURN server:

https://github.com/ant-media/Ant-Media-Server/wiki/Turn-Server-Installation with this setting:

settings.webrtc.stunServerURI=stun:YOUR_TURN_SERVER_IP:3478

Solution 5: Check open UDP Ports(5000-65000)?

 

Solution 6: Make sure your network bandwidth is high.

 

Thanks,

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share


×
×
  • Create New...