Jump to content
  • 0

Not finding IP Camera


Nathan King
 Share

Question

Hello to everyone.

I've just installed the Ant Server Community edition on Ubuntu. All went well.
I get into the web form "management of ant server", click on find IP Camera, it won't find it.

As the documentation is unclear as to the format of the "Onvif IP URL", I've tried many variables including:

192.168.1.190:554/onvif1
rtsp://192.168.1.190:554/onvif1
the above without the "onvif1"
I've tried using my ddns server, which I can view the Ant Server page.

I've opened the port, it works with OBS using:
rtsp://USER:PASS@viewsalive.ddns.net:554/onvif1

I've followed the instructions for install, including opening the appropriate ports for the Ant Server IP.

Any suggestions would be very welcomed.

Thanks.

Nathan

Link to comment
Share on other sites

  • Answers 7
  • Created
  • Last Reply

Top Posters For This Question

7 answers to this question

Recommended Posts

  • 0
Hi Nathan,

Thank you for your interest.

Option 1: Could you please send error log. We cannot understand the problem without knowing the error code.

Option 2: If your streaming is healthy in OBS, you can stream in Dashboard / Application / New Live Stream / Stream Source. Could you try and inform us please.

Thanks.
Link to comment
Share on other sites

  • 0
Hi Selim,

Thanks for your response.

Where is the log located? I'll happily provide.

I placed the stream path into Dashboard/Application/New Live Stream / Stream Source. This worked nicely for my newer IP camera. But it has now stopped finding it.
I have 2 others that don't seem to want to work. They use UDP, could this be the issue?

Also, I'm trying to publish the stream to my website. My website is a wordpress with SSL. How do I embed the signal from Ant Server into a page?
I've tried various methods, as you can see on a page on my site here:

I tried the suggestion on this post about the settings, that did nothing.

When is the new version being released? Will this enable what I want?

Thanks.

Nathan
Link to comment
Share on other sites

  • 0
Hi Nathan,

Sorry for the delay. Thank you for your patience!

Log files is in /usr/local/antmedia/log/

I have 2 others that don't seem to want to work. They use UDP, could this be the issue?
Answer: Ant Media Server currently support TCP. Doesn't support UDP. Could you please write issue in Ant Media Server Github page. https://github.com/ant-media/Ant-Media-Server  

Also, I'm trying to publish the stream to my website. My website is a wordpress with SSL. How do I embed the signal from Ant Server into a page?
Actually, you can embed like https://antmedia.io/livedemo/ Could you please review page. Also review our default player htmls in below


When is the new version being released? Will this enable what I want?
Yes, new version is released. You can find in here https://github.com/ant-media/Ant-Media-Server/releases

I'm hoping that I was able to answer your queries, Nathan. Please feel free to get back to us if you still have any questions.

May the Live Streaming be with you!
Link to comment
Share on other sites

  • 0
Hi Selim,

That seems to be a link to a working video using the Enterprise Edition. 
Firstly, I don't want to use the Enterprise Edition. I assume that I can embed my streams in my website/page using the Community version? 
Secondly, can you please provide a document that outlines how to embed the stream. If it's in your documents, I cannot find it.
It's not at all clear looking at those links as to how to place the link to the correct video stream.
The Player.html link doesn't play a video. The play.html states "Stream will start playing automatically when it is live"
Lastly, I assume that I am not being forced to buy a FlowPlayer licence?


Thanks.

Nathan
Link to comment
Share on other sites

  • 0
Hi Nathan,

I assume that I can embed my streams in my website/page using the Community version? 
Yes, you can embed your live stream in your website.

Can you please provide a document that outlines how to embed the stream
Unfortunatelly, yes there is no documentation in this situation. I will try to add tutorial as soon as possible.

Btw, If you use iframe play.html you should add your streamID parameters 

For example:
If your RTMP URL is rtmp://test.antmedia.io/LiveApp/test1234
Your StreamID is test1234


I hope, I could help you!

May the Live Streaming be with you!

Selim.

Link to comment
Share on other sites

  • 0
Hi Selim,

Thanks for the confirmation on embedding the stream. 
How do I do that?
Simply using the link including the stream number doesn't work with any players that I've tried....
The embed code that you provide via the dashboard doesn't work either.

<iframe width="560" height="315"src="//viewsalive.ddns.net:5080/LiveApp/play.html?name=410709193437777461320226"frameborder="0" allowfullscreen></iframe>

 


I noticed that you've got https - does it matter that I haven't set up my Ant Server with SSL? If so, how do I do that?


Thanks.


Nathan

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share


×
×
  • Create New...