Jump to content
  • 0

Ubuntu 20.04


Orana Wildlife Park
 Share

Question

Okay, I now know that 20.04 is not supported by Ant Media Server. But since it was installed on 18.04, and the 20.04 update applied fine, and AMS is running fine ever since I wasn't aware! I want to update to AMS 2.1 but cant...

Is there a way for me to "force" installation on 20.04?
Is there a timeline for 20.04 support?
Do I really have to roll back to 18.04?
Can I then apply 20.04?

Anyone been here before me?
Thanks
Link to comment
Share on other sites

  • Answers 22
  • Created
  • Last Reply

Top Posters For This Question

22 answers to this question

Recommended Posts

  • 0

@burak Ran the install and it generated the following:

Using old syntax to match the parameters. It's deprecated and use the new way by typing ./install_ant-media-server.sh -h
Hit:2 http://nz.archive.ubuntu.com/ubuntu focal-updates InRelease              
Hit:3 http://nz.archive.ubuntu.com/ubuntu focal-backports InRelease            
Hit:4 http://security.ubuntu.com/ubuntu focal-security InRelease               
  404  Not Found [iP: 91.189.95.83 80]
Reading package lists... Done
E: The repository 'http://ppa.launchpad.net/certbot/certbot/ubuntu focal Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
There is a problem in installing the ant media server. Please send the log of this console to contact@antmedia.io

so should I delete certbot and try without?
Link to comment
Share on other sites

  • 0

Hello Burak,

 

I'd the same problem, install Antmedia in Ubuntu 20.04.

I tried with your file "install_ant-media-server.sh".

I see this message:

 

" ● antmedia.service - AntMedia

     Loaded: loaded (/lib/systemd/system/antmedia.service; enabled; vendor pres>
     Active: activating (auto-restart) (Result: exit-code) since Mon 2020-10-26>
    Process: 2341692 ExecStart=/usr/bin/jsvc -home ${JAVA_HOME} -user antmedia >
   Main PID: 2341705 (code=exited, status=1/FAILURE)

root@xxxx:/etc/antmedia# service antmedia stop
root@xxxx:/etc/antmedia# service antmedia start
root@xxxx:/etc/antmedia# service antmedia status
● antmedia.service - AntMedia
     Loaded: loaded (/lib/systemd/system/antmedia.service; enabled; vendor pres>
     Active: activating (auto-restart) (Result: exit-code) since Mon 2020-10-26>
    Process: 2363921 ExecStart=/usr/bin/jsvc -home ${JAVA_HOME} -user antmedia >
   Main PID: 2363941 (code=exited, status=1/FAILURE)

"

 

Could'you help me ?

 

Br

Francesco Re

 

Link to comment
Share on other sites

  • 0

@burak

I ran: 

sudo add-apt-repository --remove ppa:certbot/certbot  (you were missing the "t" in the first "certbot")
sudo ./install_ant-media-server.sh ant-media-server-2.1.0-community-2.1.0-20200720_1340.zip true

and I'm pleased to report:
Synchronizing state of antmedia.service with SysV service script with /lib/systemd/systemd-sysv-install.
Executing: /lib/systemd/systemd-sysv-install enable antmedia
Created symlink /etc/systemd/system/multi-user.target.wants/antmedia.service → /lib/systemd/system/antmedia.service.
Settings are restored.
Ant Media Server is installed and started.

But I cant actually access the server on 192.168.1.10:5080:
Hmmm… can't reach this page

192.168.1.10 refused to connect.

Link to comment
Share on other sites

  • 0

Hi did this : wget https://github.com/ant-media/Scripts/blob/050194ec33a2784fed188c14c7a52a335ad5d73b/install_ant-media-server.sh && chmod 755 install_ant-media-server.sh

then:

root@vps:~# sudo ./install_ant-media-server.sh ant-media-server-2.2.1-community-2.2.1-20201029_0748.1.zip

then i get this error:

./install_ant-media-server.sh: 7: Syntax error: newline unexpected

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share


×
×
  • Create New...