Jump to content
  • 0

VoD not streaming


Orana Wildlife Park
 Share

Question

So I have a fresh install of 2.3.0 on Ubuntu 20.04. All rtsp streams have been re-entered from scratch and are accessible via browser - YIPPEE!

However, I have uploaded the six VoD streams, all mp4's. They play in AMS interface, download via AMS interface, but are not accessible from browser - AAARRGGHHH!

The browser states "Stream will start playing automatically when it is live" but never spools or plays.

In the browser console I get:
No stream found
sent message:{"command":"getStreamInfo","streamId":"546111496697119249617652"}
error callback: "no_stream_exist"
Link to comment
Share on other sites

  • Answers 5
  • Created
  • Last Reply

Top Posters For This Question

5 answers to this question

Recommended Posts

  • 0

Hello,

What URL do you exactly using for playing in the browser? Can you try this

 http://<SERVER_NAME>:5080/LiveApp/streams/<STREAM_ID>.mp4 

(or change to https and port 5443)

Also, be careful that Stream_ID is not always the same as VoD video name. 

You can quickly check the stream id from management panel -> application name - > and under actions at the right side where delete, play and other operations are located, there is a button "Copy Live Embed Code to Clipboard" if you click it and paste it somewhere it should give you a code like this

"*play.html?name=XXXXXXXXXXXXXXXXXXXX"* XXXX are the stream id of that specific VoD file

 

Link to comment
Share on other sites

  • 0

Hi cem....

With or without the .mp4 I only get "Stream will start playing automatically when it is live"

The Live Embed Code is
<iframe width="560" height="315" src="http://192.168.1.10:5080/WebRTCApp/play.html?name=546111496697119249617652" frameborder="0" allowfullscreen></iframe>

Link to comment
Share on other sites

  • 0

Hello again,

There was an issue for the VoD embed code. It requires the following parameter "playOrder=vod". I will fix the source codes. Meanwhile you can add it manually for every vod. So the following link and pattern should be fine

Best Regards,
Cem

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...