Jump to content
  • 0

Publish to RTMP - But can't play stream


Chai
 Share

Question

Hi,

We are trying to do RTMP publish via OBS. I tried OBS and Streamlabs OBS and we are having an issue playing the stream. Please see this screenshot below. 

As you can see I'm able to publish with OBS software and I can see the stream in Ant Dashboard. But, when I go to WebRTCAppEE/player.html and try to play the stream - it says "no_stream_exist".

Here is the Stream configuration from OBS and Streamlabs. 

One thing to notice, I'm using rtmp:// for OBS and https:// for Streamlabs(which is working as I expected). But most of our customers are familiar with OBS and would like to use that instead. 

Any insights or workarounds on how to RTMP publish from OBS and play the stream from player.html?

Thanks,
Chai

 

 

 

 

800798891_ScreenShot2021-06-09at2_05_38AM.thumb.png.f569b42e10ca566e44ea792d1c36fe18.png

2114097605_ScreenShot2021-06-09at2_34_12AM.thumb.png.655195d029b712a2d3a3065d9d097b71.png

791142357_ScreenShot2021-06-09at2_35_53AM.thumb.png.19b4cac21678947c7dea58c2e1d128d1.png

Link to comment
Share on other sites

  • Answers 9
  • Created
  • Last Reply

Top Posters For This Question

Top Posters For This Question

Posted Images

9 answers to this question

Recommended Posts

  • 0

Hi Chai,

Hope you are fine.

Please follow below documentation link for RTMP publishing through OBS and other encoder.

And for playing the live streams you can follow below link

You will be able to play your stream on https://your_domain:5443/(LiveApp/WebRTCAppEE)/play.html?name=streamId

Regards,

Yash

Link to comment
Share on other sites

  • 0

Hi Chai,

As I can see in Stream labs, you are using https in RTMP Url which will not work. Also you have to add "/" after the WebRTCAppEE which you have not added.

So your URL should be like rtmp://your_domain/WebRTCAppEE/

Regards,

Yash

Link to comment
Share on other sites

  • 0
Yash,

Surprisingly - Streamlabs works with https. But I still can’t play the stream from player.html - it says “no_stream_exists”, but Ant dashboard displays the video that is being streamed. 

--
Chaitanya Malla
Link to comment
Share on other sites

  • 0

Yash,

Great. Thanks for clarifying and I'm able to get it to work. I was using player.html instead of play.html and the playOrder param. 

Now that I got to work - but, there is a significant delay of 15 seconds. We use GPU 4xlarge servers with Adaptive streaming enabled and followed the recommended configurations mentioned here: https://github.com/ant-media/Ant-Media-Server/wiki/Open-Broadcaster-Software-Publishing

Any other ideas on how I can reduce the latency when streaming from OBS?

 

Link to comment
Share on other sites

  • 0

Hi Chaitanya,

To reduce the HLS latency there are some parameters and it can be reduced to 8-10 secs or less for now. Also it depends on your internet connection. Please refer below link for rtmp to hls latency

https://github.com/ant-media/Ant-Media-Server/wiki/How-to-Reduce-latency-for-RTMP-HLS-Streaming

 

In short to have about 8-10 secs latency.

  • Send key frame interval with 2 seconds in OBS
  • Make HLS segment time 2 seconds in the Ant Media Server settings

Regards,

Yash

 

 

Link to comment
Share on other sites

  • 0

Yash,

Great. thanks for the reference. We made those changes and the latency is reduced significantly. 

Now, onto the next issue - Is there a known issue with Audio/Video lag. I know it happened with some of the versions recently like 2.2 but they are claimed to be resolved. Are they any such known issues with 2.3.2?

 

Link to comment
Share on other sites

  • 0

Yash,

I just had a call with Burak about some of these issues and got suggestions on how we can improve the latency and other details. Please take a look at the email I sent with additional logs to help with debugging. 

Thanks,
Chai

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share


×
×
  • Create New...